# Domain operator ID error \[Taurus testnet\]

**URL:** <https://forum.autonomys.xyz/t/domain-operator-id-error-taurus-testnet/4709>\
**Category:** Support\
**Tags:** nodes, cli, error\
**Created:** [February 24, 2025, 10:05am UTC](https://forum.autonomys.xyz/t/domain-operator-id-error-taurus-testnet/4709 "2025-02-24T10:05:23Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Pavel\_Kochurov](https://yyz1.discourse-cdn.com/flex011/user_avatar/forum.autonomys.xyz/pavel_kochurov/32/1347_2.png) [@Pavel\_Kochurov](https://forum.autonomys.xyz/u/Pavel_Kochurov)\
**Post date:** [February 24, 2025, 10:05am UTC](https://forum.autonomys.xyz/t/domain-operator-id-error-taurus-testnet/4709/1 "2025-02-24T10:05:23Z")

</div>

## Issue Report

I’ve made an operator ID file, get public key (starting 0x7285..), used it in registration process on astral portal and register an operator ID #149. But when I entered this operator ID into my node starting parameters it returns me the following errors (see screenshots), while the required file is present in the specified directory. What can be the reason and how to solve it?

 ![sub1](https://canada1.discourse-cdn.com/flex011/uploads/subspace/original/2X/9/9c467479a57d051ce692aa0b6052cfc47d92c912.png)  
 ![Screenshot_13](https://canada1.discourse-cdn.com/flex011/uploads/subspace/original/2X/7/70bfaf94cd6b9ae4aa49ff442b071664ab342c87.png)

starting parameters:  
./node run   
–chain taurus   
–name AON-Taurus   
–base-path /NODE/   
–blocks-pruning archive-canonical   
–state-pruning archive-canonical   
–sync full   
–   
–domain-id 0   
–operator-id 149   
–blocks-pruning archive-canonical   
–state-pruning 16000

### Environment

- ubuntu 22.04
- Advanced CLI, Taurus testnet ver of 28 january

### Problem

describe above

```auto
see screens

```

---

<div class="post-metadata">

**Author:** ![DrGrvty](https://avatars.discourse-cdn.com/v4/letter/d/90ced4/32.png) [@DrGrvty](https://forum.autonomys.xyz/u/DrGrvty)\
**Post date:** [February 24, 2025, 3:10pm UTC](https://forum.autonomys.xyz/t/domain-operator-id-error-taurus-testnet/4709/2 "2025-02-24T15:10:03Z")

</div>

I’m not sure I can help you, but if you include your exact starting command it might help when someone smarter comes along. For instance, what is your --base-path given as? --base-path ./NODE ?  
And do you get a `INFO subspace\_node::commands::run: 💾 Node path: ./NODE’  
log on startup?  
I had the missing key message, but I had started a new db and forgot to copy the keystore folder to the new db location.

---

<div class="post-metadata">

**Author:** ![Pavel\_Kochurov](https://yyz1.discourse-cdn.com/flex011/user_avatar/forum.autonomys.xyz/pavel_kochurov/32/1347_2.png) [@Pavel\_Kochurov](https://forum.autonomys.xyz/u/Pavel_Kochurov)\
**Post date:** [February 24, 2025, 4:06pm UTC](https://forum.autonomys.xyz/t/domain-operator-id-error-taurus-testnet/4709/3 "2025-02-24T16:06:41Z")

</div>

you’re definitely right (done)

---

<div class="post-metadata">

**Author:** ![Pavel\_Kochurov](https://yyz1.discourse-cdn.com/flex011/user_avatar/forum.autonomys.xyz/pavel_kochurov/32/1347_2.png) [@Pavel\_Kochurov](https://forum.autonomys.xyz/u/Pavel_Kochurov)\
**Post date:** [February 27, 2025, 4:20pm UTC](https://forum.autonomys.xyz/t/domain-operator-id-error-taurus-testnet/4709/4 "2025-02-27T16:20:03Z")

</div>

solved with:  
./node domain key insert --base-path /NODE/ --domain-id 0 --keystore-suri “seed phrase here”
