# Is there any option to force farmer to reconnect to its node that I'm not aware of?

**URL:** <https://forum.autonomys.xyz/t/is-there-any-option-to-force-farmer-to-reconnect-to-its-node-that-im-not-aware-of/2331>\
**Category:** Support\
**Created:** [January 4, 2024, 4:07am UTC](https://forum.autonomys.xyz/t/is-there-any-option-to-force-farmer-to-reconnect-to-its-node-that-im-not-aware-of/2331 "2024-01-04T04:07:27Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![dragonP](https://yyz1.discourse-cdn.com/flex011/user_avatar/forum.autonomys.xyz/dragonp/32/716_2.png) [@dragonP](https://forum.autonomys.xyz/u/dragonP)\
**Post date:** [January 4, 2024, 4:07am UTC](https://forum.autonomys.xyz/t/is-there-any-option-to-force-farmer-to-reconnect-to-its-node-that-im-not-aware-of/2331/1 "2024-01-04T04:07:27Z")

</div>

When my node is closed, all of its connecting farmers (both local and remote in LAN) have the following error:

2024-01-04T02:06:29.353988Z ERROR jsonrpsee\_core::client::async\_client: [backend]: Networking or low-level protocol error: WebSocket connection error: i/o error: An existing connection was forcibly closed by the remote host. (os error 10054)

In order to resume, I always have to run node and all farmers again. Is it possible to just run the node and all of its connecting farmers will resume the connection to the node automatically when it’s live again?

---

<div class="post-metadata">

**Author:** ![nazar-pc](https://yyz1.discourse-cdn.com/flex011/user_avatar/forum.autonomys.xyz/nazar-pc/32/6_2.png) [@nazar-pc](https://forum.autonomys.xyz/u/nazar-pc)\
**Post date:** [January 4, 2024, 10:02am UTC](https://forum.autonomys.xyz/t/is-there-any-option-to-force-farmer-to-reconnect-to-its-node-that-im-not-aware-of/2331/2 "2024-01-04T10:02:57Z")

</div>

I’m not sure why you have to run the node again, and either way you should have some restarting mechanism for farmers. So when farmer disconnects and shuts down, it will just restart and reconnect to the node again.

---

<div class="post-metadata">

**Author:** ![dragonP](https://yyz1.discourse-cdn.com/flex011/user_avatar/forum.autonomys.xyz/dragonp/32/716_2.png) [@dragonP](https://forum.autonomys.xyz/u/dragonP)\
**Post date:** [January 4, 2024, 12:44pm UTC](https://forum.autonomys.xyz/t/is-there-any-option-to-force-farmer-to-reconnect-to-its-node-that-im-not-aware-of/2331/3 "2024-01-04T12:44:12Z")

</div>

There’re 2 scenario:

1. The node instance just stop/close for no reason
2. The PC where I run the node is rebooted

In both scenario, the farmers at the remote PC have above error and all stop. Even when I run the node again, they’re not automatically reconnected (I have to close the farmer instance one by one and open it again to connect to the node). So if we can make them reconnect to its node, it’d be great.

---

<div class="post-metadata">

**Author:** ![nazar-pc](https://yyz1.discourse-cdn.com/flex011/user_avatar/forum.autonomys.xyz/nazar-pc/32/6_2.png) [@nazar-pc](https://forum.autonomys.xyz/u/nazar-pc)\
**Post date:** [January 4, 2024, 1:50pm UTC](https://forum.autonomys.xyz/t/is-there-any-option-to-force-farmer-to-reconnect-to-its-node-that-im-not-aware-of/2331/4 "2024-01-04T13:50:40Z")

</div>

Feel free to contribute, but it is typically much easier to restart the whole farmer rather than implementing reconnection. Also connecting remote farmers is not the intended usage scenario, even though some users do that.
