# Thread 'main' panicked at 'Failed to make runtime API call during last archived block search: UnknownBlock

**URL:** <https://forum.autonomys.xyz/t/thread-main-panicked-at-failed-to-make-runtime-api-call-during-last-archived-block-search-unknownblock/1674>\
**Category:** Support\
**Tags:** nodes, cli\
**Created:** [September 1, 2023, 8:27pm UTC](https://forum.autonomys.xyz/t/thread-main-panicked-at-failed-to-make-runtime-api-call-during-last-archived-block-search-unknownblock/1674 "2023-09-01T20:27:08Z")\
**Posts on this page:** 11\
**Page:** 1

<div class="post-metadata">

**Author:** ![Motko222](https://yyz1.discourse-cdn.com/flex011/user_avatar/forum.autonomys.xyz/motko222/32/1118_2.png) [@Motko222](https://forum.autonomys.xyz/u/Motko222)\
**Post date:** [September 1, 2023, 8:27pm UTC](https://forum.autonomys.xyz/t/thread-main-panicked-at-failed-to-make-runtime-api-call-during-last-archived-block-search-unknownblock/1674/1 "2023-09-01T20:27:08Z")

</div>

## Issue Report

Not sure if related, but happened after the node run out of disk space.

### Environment

- Ubuntu 22.04.3 LTS
- Advanced CLI

### Problem

2023-09-01 22:15:50 Subspace  
2023-09-01 22:15:50 ✌ version 0.1.0-a5336b5f501  
2023-09-01 22:15:50 ❤ by Subspace Labs [https://subspace.network](https://subspace.network), 2021-2023  
2023-09-01 22:15:50 📋 Chain specification: Subspace Gemini 3f  
2023-09-01 22:15:50 🏷 Node name: motko1  
2023-09-01 22:15:50 👤 Role: AUTHORITY  
2023-09-01 22:15:50 💾 Database: ParityDb at /mnt/Buffer/subspace1/chains/subspace\_gemini\_3f/paritydb/full  
2023-09-01 22:15:50 ⛓ Native runtime: subspace-2 (subspace-0.tx0.au0)  
2023-09-01 22:15:52 [Consensus] DSN instance configured. allow\_non\_global\_addresses\_in\_dht=false peer\_id=12D3KooWJr9wgCHD4sh5LLVRNWWJQM7R5v3WLeR8sqD5HFt1EKwW protocol\_version=/\>  
2023-09-01 22:15:52 [Consensus] Subspace networking initialized: Node ID is 12D3KooWJr9wgCHD4sh5LLVRNWWJQM7R5v3WLeR8sqD5HFt1EKwW  
2023-09-01 22:15:52 [Consensus] DSN listening on /ip4/127.0.0.1/tcp/30433/p2p/12D3KooWJr9wgCHD4sh5LLVRNWWJQM7R5v3WLeR8sqD5HFt1EKwW  
2023-09-01 22:15:52 [Consensus] DSN listening on /ip4/10.0.4.199/tcp/30433/p2p/12D3KooWJr9wgCHD4sh5LLVRNWWJQM7R5v3WLeR8sqD5HFt1EKwW  
2023-09-01 22:15:52 [Consensus] 🏷 Local node identity is: 12D3KooWJr9wgCHD4sh5LLVRNWWJQM7R5v3WLeR8sqD5HFt1EKwW  
2023-09-01 22:15:53 [Consensus] Added observed address as external: /ip4/193.87.163.5/tcp/30433  
2023-09-01 22:16:08 [Consensus] Public address status changed. old=Unknown new=Private

====================

Version: 0.1.0-a5336b5f501

0: sp\_panic\_handler::set::{{closure}}  
1: std::panicking::rust\_panic\_with\_hook  
2: std::panicking::begin\_panic\_handler::{{closure}}  
3: std::sys\_common::backtrace::\_\_rust\_end\_short\_backtrace  
4: rust\_begin\_unwind  
5: core::panicking::panic\_fmt  
6: subspace\_service::new\_full::{{closure}}  
7: subspace\_node::main::{{closure}}::{{closure}}  
8: sc\_cli:🏃‍♂️:Runner::run\_node\_until\_exit  
9: subspace\_node::main  
10: std::sys\_common::backtrace::\_\_rust\_begin\_short\_backtrace  
11: std::rt::lang\_start::{{closure}}  
12: main  
13: \_\_libc\_start\_call\_main  
at ./csu/../sysdeps/nptl/libc\_start\_call\_main.h:58:16  
14: \_\_libc\_start\_main\_impl  
at ./csu/../csu/libc-start.c:392:3  
15: \_start

Thread ‘main’ panicked at 'Failed to make runtime API call during last archived block search: UnknownBlock("State already discarded for 0xdf1cff42ae685ed432e26134c171b0f3f7c0ff\>

This is a bug. Please report it at:

```
    https://forum.autonomys.xyz

```

---

<div class="post-metadata">

**Author:** ![ImmaZoni](https://yyz1.discourse-cdn.com/flex011/user_avatar/forum.autonomys.xyz/immazoni/32/7_2.png) [@ImmaZoni](https://forum.autonomys.xyz/u/ImmaZoni)\
**Post date:** [September 2, 2023, 12:04am UTC](https://forum.autonomys.xyz/t/thread-main-panicked-at-failed-to-make-runtime-api-call-during-last-archived-block-search-unknownblock/1674/2 "2023-09-02T00:04:44Z")

</div>

Hey @Motko222 thank you for the submission!

You mentioned that this occurs when the node runs out of disk space? You may need to cleanup some space, or lower your plot size if this is occurring. Once their is space available you should be able to restart your farmer with no issues.

Feel free to get back to me and let me know if this issue persists even with available space.

---

<div class="post-metadata">

**Author:** ![Motko222](https://yyz1.discourse-cdn.com/flex011/user_avatar/forum.autonomys.xyz/motko222/32/1118_2.png) [@Motko222](https://forum.autonomys.xyz/u/Motko222)\
**Post date:** [September 2, 2023, 6:22am UTC](https://forum.autonomys.xyz/t/thread-main-panicked-at-failed-to-make-runtime-api-call-during-last-archived-block-search-unknownblock/1674/3 "2023-09-02T06:22:49Z")

</div>

Hi, already did that, did not help.

---

<div class="post-metadata">

**Author:** ![nazar-pc](https://yyz1.discourse-cdn.com/flex011/user_avatar/forum.autonomys.xyz/nazar-pc/32/6_2.png) [@nazar-pc](https://forum.autonomys.xyz/u/nazar-pc)\
**Post date:** [September 2, 2023, 3:24pm UTC](https://forum.autonomys.xyz/t/thread-main-panicked-at-failed-to-make-runtime-api-call-during-last-archived-block-search-unknownblock/1674/4 "2023-09-02T15:24:10Z")

</div>

If you ran out of space database might be corrupted. I think you’ll need to wipe the node and start again. Farmer doesn’t need to be wiped.

---

<div class="post-metadata">

**Author:** ![Motko222](https://yyz1.discourse-cdn.com/flex011/user_avatar/forum.autonomys.xyz/motko222/32/1118_2.png) [@Motko222](https://forum.autonomys.xyz/u/Motko222)\
**Post date:** [September 2, 2023, 9:17pm UTC](https://forum.autonomys.xyz/t/thread-main-panicked-at-failed-to-make-runtime-api-call-during-last-archived-block-search-unknownblock/1674/5 "2023-09-02T21:17:31Z")

</div>

Yes, I wiped the node and it is syncing again. Thanks!

---

<div class="post-metadata">

**Author:** ![Motko222](https://yyz1.discourse-cdn.com/flex011/user_avatar/forum.autonomys.xyz/motko222/32/1118_2.png) [@Motko222](https://forum.autonomys.xyz/u/Motko222)\
**Post date:** [September 16, 2023, 5:38pm UTC](https://forum.autonomys.xyz/t/thread-main-panicked-at-failed-to-make-runtime-api-call-during-last-archived-block-search-unknownblock/1674/6 "2023-09-16T17:38:01Z")

</div>

Hello, I have this problem again with another node. It would appear it is not related to the lack of disk space.  
This time, node was stuck at block 433530. I have tried to restart and getting this error again.

---

<div class="post-metadata">

**Author:** ![nazar-pc](https://yyz1.discourse-cdn.com/flex011/user_avatar/forum.autonomys.xyz/nazar-pc/32/6_2.png) [@nazar-pc](https://forum.autonomys.xyz/u/nazar-pc)\
**Post date:** [September 17, 2023, 3:12am UTC](https://forum.autonomys.xyz/t/thread-main-panicked-at-failed-to-make-runtime-api-call-during-last-archived-block-search-unknownblock/1674/7 "2023-09-17T03:12:13Z")

</div>

So node was synced, then went de-synced, you have restarted it and it broke like that? Did I udnerstand it correctly?

If so can you provide as much logs as possible before restart and then with this crash right after? It’ll help with understanding what is going on there.

---

<div class="post-metadata">

**Author:** ![Motko222](https://yyz1.discourse-cdn.com/flex011/user_avatar/forum.autonomys.xyz/motko222/32/1118_2.png) [@Motko222](https://forum.autonomys.xyz/u/Motko222)\
**Post date:** [September 17, 2023, 7:08am UTC](https://forum.autonomys.xyz/t/thread-main-panicked-at-failed-to-make-runtime-api-call-during-last-archived-block-search-unknownblock/1674/8 "2023-09-17T07:08:27Z")

</div>

Will try to reproduce and save logs.  
Now I have realized, I was still using start scripts from Gemini II and was starting the node like this: “–execution wasm --state-pruning 1024 --keep-blocks 1024 --validator”.  
Could that be the problem?

---

<div class="post-metadata">

**Author:** ![nazar-pc](https://yyz1.discourse-cdn.com/flex011/user_avatar/forum.autonomys.xyz/nazar-pc/32/6_2.png) [@nazar-pc](https://forum.autonomys.xyz/u/nazar-pc)\
**Post date:** [September 17, 2023, 1:33pm UTC](https://forum.autonomys.xyz/t/thread-main-panicked-at-failed-to-make-runtime-api-call-during-last-archived-block-search-unknownblock/1674/9 "2023-09-17T13:33:05Z")

</div>

> [@Motko222](#):
>
> –state-pruning 1024

This is your problem! Such value is not supported, you should use `archive` instead. State will still be pruned, but only when it is safe to do so.

---

<div class="post-metadata">

**Author:** ![Motko222](https://yyz1.discourse-cdn.com/flex011/user_avatar/forum.autonomys.xyz/motko222/32/1118_2.png) [@Motko222](https://forum.autonomys.xyz/u/Motko222)\
**Post date:** [September 17, 2023, 1:38pm UTC](https://forum.autonomys.xyz/t/thread-main-panicked-at-failed-to-make-runtime-api-call-during-last-archived-block-search-unknownblock/1674/10 "2023-09-17T13:38:08Z")

</div>

Yes sir, thanks! Already tried with archive and I can restart the node without problems.  
However, I do have nodes running with state prunning, what is the drill here? Wipe node and plot or just the node?

---

<div class="post-metadata">

**Author:** ![nazar-pc](https://yyz1.discourse-cdn.com/flex011/user_avatar/forum.autonomys.xyz/nazar-pc/32/6_2.png) [@nazar-pc](https://forum.autonomys.xyz/u/nazar-pc)\
**Post date:** [September 17, 2023, 2:00pm UTC](https://forum.autonomys.xyz/t/thread-main-panicked-at-failed-to-make-runtime-api-call-during-last-archived-block-search-unknownblock/1674/11 "2023-09-17T14:00:05Z")

</div>

Just the node, nothing wrong with your plot in this case.
